ImpressCMS proudly uses SourceForge
ImpressCMS on Ohloh.net
[NewIndex :: Development :: This page]  
Tags: Development   Incomplete   Guidelines   1.3   Upgrading  

Updating modules for ImpressCMS 1.3

Summary

ImpressCMS 1.3 replaces the majority of the previous release core, with a revised structure for PHP 5.2 and above.
 
The code is kept largely compatible with previous releases, except in cases mostly created by PHP 5.2 standard changes.
 
Compatibility is made by using functions in the previous locations of code, which call the new location. During this process you will see  "deprecated" notices to advise you on the fact.
 
A full list of functions can be found in the "docs" directory of 1.3, in the included spreadsheet titled: impresscms_1.3_refactoring.ods
 
In many cases, simply replacing the function with the new one is sufficient to remove the "deprecated" notification. However other changes to the code may be required.
 
(incomplete - more to follow)
Last modified on 2011/10/23 by skenow
This page was created on 2011/3/27 by davidl2
This page has been viewed 1120 time(s)

Comments
The comments are owned by the poster. We aren't responsible for their content.
ImpressCMS proudly uses SourceForge
ImpressCMS on Ohloh.net